ViewScheduleRowHeight Property

Defines the schedule body rows height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double RowHeight { get; set; }

Property Value

Double
The row height for any body rows in the schedule.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: The given value for rowHeight must be between 0 and 30000 feet.
InvalidOperationException The RowHeightOverride property is set to RowHeightOverrideOptions.None.
Remarks

Setting this property will force all or image only (depending on how RowHeightOverride is defined) schedule body rows to be resized to the indicated height value (when viewed as a ScheduleSheetInstance on a ViewSheet). If the value that is set is smaller than the height of the text (single or multi line), then that value is not taken into account. To access or set this property the RowHeightOverride property should not be None

See Also