DividedSurfaceGetGridSegmentReference Method

Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference GetGridSegmentReference(
	GridNode gridNode,
	GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode  GridNode
 
gridSegmentDirection  GridSegmentDirection
 

Return Value

Reference
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionThrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.
See Also