RebarBarTypeGetHookLength Method |
Identifies the hook length for a hook type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetHookLength(
ElementId hookId
)
Public Function GetHookLength (
hookId As ElementId
) As Double
public:
double GetHookLength(
ElementId^ hookId
)
member GetHookLength :
hookId : ElementId -> float
Parameters
- hookId ElementId
-
id of the hook type
Return Value
Double
The hook length for a hook type
Exceptions
Remarks
If the AutoCalcHookLengths property is turned off, the default hook length will be returned
See Also