PlaneCreateByNormalAndOrigin Method |
Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface.
The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Plane CreateByNormalAndOrigin(
XYZ normal,
XYZ origin
)
Public Shared Function CreateByNormalAndOrigin (
normal As XYZ,
origin As XYZ
) As Plane
public:
static Plane^ CreateByNormalAndOrigin(
XYZ^ normal,
XYZ^ origin
)
static member CreateByNormalAndOrigin :
normal : XYZ *
origin : XYZ -> Plane
Parameters
- normal XYZ
-
Plane normal. Expected to be a valid non-zero length vector. Doesn't need to be a unit vector.
- origin XYZ
-
Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
Return Value
Plane
Exceptions
Remarks
This function does not guarantee a specific parameterization of the created Plane. Use Plane.Create(Frame) to enforce a specific parameterization of the created Plane object.
Example
XYZ normal = XYZ.BasisZ;
XYZ origin = XYZ.Zero;
Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);
Dim normal As XYZ = XYZ.BasisZ
Dim origin As XYZ = XYZ.Zero
Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also