ElementTransformUtilsMoveElement Method |
Moves one element by a given transformation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void MoveElement(
Document document,
ElementId elementToMove,
XYZ translation
)
Public Shared Sub MoveElement (
document As Document,
elementToMove As ElementId,
translation As XYZ
)
public:
static void MoveElement(
Document^ document,
ElementId^ elementToMove,
XYZ^ translation
)
static member MoveElement :
document : Document *
elementToMove : ElementId *
translation : XYZ -> unit
Parameters
- document Document
-
The document that owns the elements.
- elementToMove ElementId
-
The id of the element to move.
- translation XYZ
-
The translation vector for the elements.
Exceptions
Examplepublic void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
LocationPoint columnLocation = column.Location as LocationPoint;
XYZ oldPlace = columnLocation.Point;
XYZ newPlace = new XYZ(10, 20, 30);
ElementTransformUtils.MoveElement(document, column.Id, newPlace);
columnLocation = column.Location as LocationPoint;
XYZ newActual = columnLocation.Point;
string info = "Original Z location: " + oldPlace.Z +
"\nNew Z location: " + newActual.Z;
TaskDialog.Show("Revit",info);
}
Public Sub MoveColumn(document As Autodesk.Revit.DB.Document, column As FamilyInstance)
Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)
Dim oldPlace As XYZ = columnLocation.Point
Dim newPlace As New XYZ(10, 20, 30)
ElementTransformUtils.MoveElement(document, column.Id, newPlace)
columnLocation = TryCast(column.Location, LocationPoint)
Dim newActual As XYZ = columnLocation.Point
Dim info As String = ("Original Z location: " + oldPlace.Z & vbLf & "New Z location: ") + newActual.Z
TaskDialog.Show("Revit", info)
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also