AssemblyViewUtilsCreatePartList(Document, ElementId) Method |
Creates a new part list multicategory schedule assembly view for the assembly instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ViewSchedule CreatePartList(
Document document,
ElementId assemblyInstanceId
)
Public Shared Function CreatePartList (
document As Document,
assemblyInstanceId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreatePartList(
Document^ document,
ElementId^ assemblyInstanceId
)
static member CreatePartList :
document : Document *
assemblyInstanceId : ElementId -> ViewSchedule
Parameters
- document Document
-
The document to which the view will be added.
- assemblyInstanceId ElementId
-
Id of the assembly instance that owns the new view.
Return Value
ViewSchedule
A new part list multicategory schedule assembly view.
Exceptions
Remarks
The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count".
The document must be regenerated before using the schedule.
See Also