ComponentRepeaterSlotFamilyType Property |
The id of the family type of the component in the slot, or invalid id if the slot is empty.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId FamilyType { get; set; }
Public Property FamilyType As ElementId
Get
Set
public:
property ElementId^ FamilyType {
ElementId^ get ();
void set (ElementId^ value);
}
member FamilyType : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Invalid type for the slot. The type must be an adaptive family with no shape handles.
In addition, it must have same category and same number of placement points as the current type of the repeater.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also