FamilyUtilsConvertFamilyToFaceHostBased Method |
Converts a family to be face host based.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void ConvertFamilyToFaceHostBased(
Document document,
ElementId familyId
)
Public Shared Sub ConvertFamilyToFaceHostBased (
document As Document,
familyId As ElementId
)
public:
static void ConvertFamilyToFaceHostBased(
Document^ document,
ElementId^ familyId
)
static member ConvertFamilyToFaceHostBased :
document : Document *
familyId : ElementId -> unit
Parameters
- document Document
-
The document containing the family to be converted.
- familyId ElementId
-
The family id.
Exceptions
Remarks
Converts a family hosted by some element other than a face to be hosted by a face. This is done by replacing the existing host (wall, roof, ceiling, floor) with a face.
Conversion can succeed only if FamilyUtils.FamilyCanConvertToFaceHostBased() returns true.
See Also