ConceptualConstructionTypeGetRoofConstructionType Method |
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetRoofConstructionType(
Document ccda,
ConceptualConstructionRoofType typeEnum
)
Public Shared Function GetRoofConstructionType (
ccda As Document,
typeEnum As ConceptualConstructionRoofType
) As ElementId
public:
static ElementId^ GetRoofConstructionType(
Document^ ccda,
ConceptualConstructionRoofType typeEnum
)
static member GetRoofConstructionType :
ccda : Document *
typeEnum : ConceptualConstructionRoofType -> ElementId
Parameters
- ccda Document
-
The Document.
- typeEnum ConceptualConstructionRoofType
-
The ConceptualConstructionRoofType to get the ConceptualConstructionType for.
Return Value
ElementId
Returns ElementId of a ConceptualConstructionType.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
The enum is invalid for ConceptualConstructionRoofType.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also