ParameterUtilsDownloadCompanyName Method |
Downloads the name of the given parameter's owning account and records it in the given document. If the owning
account's name is already recorded in the given document, this method returns the name without downloading it
again.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static string DownloadCompanyName(
Document document,
ForgeTypeId parameterTypeId
)
Public Shared Function DownloadCompanyName (
document As Document,
parameterTypeId As ForgeTypeId
) As String
public:
static String^ DownloadCompanyName(
Document^ document,
ForgeTypeId^ parameterTypeId
)
static member DownloadCompanyName :
document : Document *
parameterTypeId : ForgeTypeId -> string
Parameters
- document Document
-
Document in which to record the name of the parameter's owning account.
- parameterTypeId ForgeTypeId
-
Parameter identifier.
Return Value
String
Name of the owning account.
Exceptions
Remarks
In Revit, the account name appears in the parameter tooltip if available.
See Also