CurveElementHasTangentJoin Method |
Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HasTangentJoin(
int end,
ElementId other
)
Public Function HasTangentJoin (
end As Integer,
other As ElementId
) As Boolean
public:
bool HasTangentJoin(
int end,
ElementId^ other
)
member HasTangentJoin :
end : int *
other : ElementId -> bool
Parameters
- end Int32
-
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
- other ElementId
-
ElementId of another Curve Element from the same document.
Return Value
Boolean
Returns True if the two curve elements have a tangent join at the given end-point.
Exceptions
See Also