ViewSetElementOverrides Method

Sets graphic overrides for an element in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetElementOverrides(
	ElementId elementId,
	OverrideGraphicSettings overrideGraphicSettings
)

Parameters

elementId  ElementId
Element to override.
overrideGraphicSettings  OverrideGraphicSettings
An object representing all graphic overrides of the element in view.
Exceptions
ExceptionCondition
ArgumentException elementId is not a valid Element identifier. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
ArgumentNullException A non-optional argument was null
InvalidOperationException The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also