RebarSpliceSplicePosition Property |
Identifies the splice position.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarSplicePosition SplicePosition { get; set; }
Public Property SplicePosition As RebarSplicePosition
Get
Set
public:
property RebarSplicePosition SplicePosition {
RebarSplicePosition get ();
void set (RebarSplicePosition value);
}
member SplicePosition : RebarSplicePosition with get, set
Property Value
RebarSplicePosition
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
This property describes the position of the splice face with respect to each bar end involved in splice.
Middle describes the behavior when both bar ends extends with half of the lap length and the splice plane sits between them.
End1 and End2 describes the behavior when one of the bar ends is on the splice plane and the other bar end extends with the lap length.
End1 means that the lap is computed towards the start of the splice chain, while End2 means that the lap is computed towards the end of the splice chain.
For more information about the splice chain concept please check Autodesk.Revit.DB.Structure.RebarSpliceUtils.GetSpliceChain(Rebar rebar).
See Also