FlexDuctIsFlexDuctTypeId Method |
Checks if given type is valid flexible duct type.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsFlexDuctTypeId(
Document document,
ElementId ductTypeId
)
Public Shared Function IsFlexDuctTypeId (
document As Document,
ductTypeId As ElementId
) As Boolean
public:
static bool IsFlexDuctTypeId(
Document^ document,
ElementId^ ductTypeId
)
static member IsFlexDuctTypeId :
document : Document *
ductTypeId : ElementId -> bool
Parameters
- document Document
-
The document.
- ductTypeId ElementId
-
ElementId of the flexible duct type to check.
Return Value
Boolean
True if flexible duct type can used for this duct, false otherwise.
Exceptions
Remarks
A type is valid for flexible duct if it can be used to the flexible duct element.
See Also