ViewIsFilterApplied Method

Indicates if a filter is applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsFilterApplied(
	ElementId filterElementId
)

Parameters

filterElementId  ElementId
ElementId of the filter.

Return Value

Boolean
True if the filter is applied to the view, false otherwise.
Exceptions
ExceptionCondition
ArgumentException ElementId is not associated with a FilterElement.
ArgumentNullException A non-optional argument was null
InvalidOperationException The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also