DirectShapeGetExternallyTaggedGeometry Method

Gets the externally tagged geometry by its external ID that is stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
	ExternalGeometryId externalId
)

Parameters

externalId  ExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.

Return Value

ExternallyTaggedGeometryObject
The externally tagged geometry. Or if there is no such externally tagged geometry in the DirectShape.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also