AnalyticalMemberSetCurve Method

Sets the curve for the Analytical Member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCurve(
	Curve curve
)

Parameters

curve  Curve
 
Exceptions
ExceptionCondition
ArgumentException The input curve is not bound. -or- The provided curve is not supported.
ArgumentNullException A non-optional argument was null
Remarks
End nodes connection will be lost if the curve changes position. The curve must be bounded. The curve can be:
  • Line
  • Arc
  • Ellipse
See Also