ParameterFilterElementSetCategories Method |
Sets the categories admitted by this filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCategories(
ICollection<ElementId> categories
)
Public Sub SetCategories (
categories As ICollection(Of ElementId)
)
public:
void SetCategories(
ICollection<ElementId^>^ categories
)
member SetCategories :
categories : ICollection<ElementId> -> unit
Parameters
- categories ICollectionElementId
-
Exceptions
RemarksTesting that an element's category is a member of this set is,
essentially, the first rule of the filter.
Changing the set of categories will clear any rules that use parameters
that are not applicable for the new set of categories.
See Also