TopographySurfaceIsValidRegion Method |
Identify whether the points can construct a valid region for a topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidRegion(
IList<XYZ> points
)
Public Shared Function IsValidRegion (
points As IList(Of XYZ)
) As Boolean
public:
static bool IsValidRegion(
IList<XYZ^>^ points
)
static member IsValidRegion :
points : IList<XYZ> -> bool
Parameters
- points IListXYZ
-
The points set to be checked.
Return Value
Boolean
True if the size of points is not less than 3 and the points are not collinear after projecting to XY plane, that is, ignoring the elevation.
Exceptions
See Also