PartOriginalCategoryId Property |
The category Id of the original element corresponding to this Part.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId OriginalCategoryId { get; set; }
Public Property OriginalCategoryId As ElementId
Get
Set
public:
property ElementId^ OriginalCategoryId {
ElementId^ get ();
void set (ElementId^ value);
}
member OriginalCategoryId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: dPartOriginalCategoryId is not an available member of the original category ids of the elements which formed this Part.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also