SpanDirectionSymbolCreate Method |
Places a new instance of the Span Direction Symbol into the project relative to a particular host element and view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static SpanDirectionSymbol Create(
Document document,
ElementId viewId,
LinkElementId elemIdToTag,
XYZ headPosistion,
ElementId symbolId
)
Public Shared Function Create (
document As Document,
viewId As ElementId,
elemIdToTag As LinkElementId,
headPosistion As XYZ,
symbolId As ElementId
) As SpanDirectionSymbol
public:
static SpanDirectionSymbol^ Create(
Document^ document,
ElementId^ viewId,
LinkElementId^ elemIdToTag,
XYZ^ headPosistion,
ElementId^ symbolId
)
static member Create :
document : Document *
viewId : ElementId *
elemIdToTag : LinkElementId *
headPosistion : XYZ *
symbolId : ElementId -> SpanDirectionSymbol
Parameters
- document Document
-
The document.
- viewId ElementId
-
The id of the view in which the symbol should appear.
- elemIdToTag LinkElementId
-
The ElementId of a Floor (either in the document or linked from another document).
- headPosistion XYZ
-
The span symbol's head position.
- symbolId ElementId
-
The id of the family symbol of this span symbol.
Return Value
SpanDirectionSymbol
Returns the newly created symbol.
ExceptionsException | Condition |
---|
ArgumentException |
The specified viewId should represent a Plan View.
-or-
The specified elemIdToTag should represent a Floor element.
-or-
The specified symbolId isn't valid. It should be a FamilySymbol of OST_SpanDirectionSymbol category.
|
ArgumentNullException |
A non-optional argument was null
|
See Also