BoundaryConditionsAssociatedLoadId Property |
The Id of the internal load element associated with a boundary conditions.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId AssociatedLoadId { get; set; }
Public Property AssociatedLoadId As ElementId
Get
Set
public:
property ElementId^ AssociatedLoadId {
ElementId^ get ();
void set (ElementId^ value);
}
member AssociatedLoadId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: elementId is not a valid Element identifier.
-or-
When setting this property: Throws when the ElementId does not refer to the internal load with appropriate type.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
ElementId may be set if the internal load exists and it's type fit the BoundaryConditions type only (Point, Line and Area).
See Also