TextElementVerticalAlignment Property |
Vertical alignment of the text.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VerticalTextAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalTextAlignment
Get
Set
public:
property VerticalTextAlignment VerticalAlignment {
VerticalTextAlignment get ();
void set (VerticalTextAlignment value);
}
member VerticalAlignment : VerticalTextAlignment with get, set
Property Value
VerticalTextAlignment
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
The vertical alignment determines the way text is positioned as the text height changes.
- For Top-aligned text the top of the text will remain in place.
- For Middle-aligned text the horizontal center line of the text will remain in place.
- For Bottom-aligned text the bottom of the text will remain in place.
Changing this property will not affect the position of the text element.
See Also