AssemblyViewUtilsAcquireAssemblyViews Method |
Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void AcquireAssemblyViews(
Document document,
ElementId sourceAssemblyInstanceId,
ElementId targetAssemblyInstanceId
)
Public Shared Sub AcquireAssemblyViews (
document As Document,
sourceAssemblyInstanceId As ElementId,
targetAssemblyInstanceId As ElementId
)
public:
static void AcquireAssemblyViews(
Document^ document,
ElementId^ sourceAssemblyInstanceId,
ElementId^ targetAssemblyInstanceId
)
static member AcquireAssemblyViews :
document : Document *
sourceAssemblyInstanceId : ElementId *
targetAssemblyInstanceId : ElementId -> unit
Parameters
- document Document
-
The document in which the assembly instances live.
- sourceAssemblyInstanceId ElementId
-
Id of the assembly instance that currently owns the assembly views.
- targetAssemblyInstanceId ElementId
-
Id of the assembly instance which will become the new owner of the assembly views.
ExceptionsException | Condition |
---|
ArgumentException |
sourceAssemblyInstanceId is not an AssemblyInstance with assembly views.
-or-
targetAssemblyInstanceId is not an AssemblyInstance.
-or-
sourceAssemblyInstanceId and targetAssemblyInstanceId are not AssemblyInstances from the same assembly type.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also