ElectricalAnalyticalNodeDisconnectFromUpstreamNode Method |
Disconnects from upstream node.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void DisconnectFromUpstreamNode(
ElementId upstreamNodeId
)
Public Sub DisconnectFromUpstreamNode (
upstreamNodeId As ElementId
)
public:
void DisconnectFromUpstreamNode(
ElementId^ upstreamNodeId
)
member DisconnectFromUpstreamNode :
upstreamNodeId : ElementId -> unit
Parameters
- upstreamNodeId ElementId
-
The upstream node id to disconnect from.
ExceptionsException | Condition |
---|
ArgumentException |
The id is not an analytical distribution node id.
-or-
The analytical distribution node can not disconnect from the upstream node.
|
ArgumentNullException |
A non-optional argument was null
|
See Also