PolymeshTopologyGetFacet Method |
Returns a definition of one facet
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PolymeshFacet GetFacet(
int idx
)
Public Function GetFacet (
idx As Integer
) As PolymeshFacet
public:
PolymeshFacet^ GetFacet(
int idx
)
member GetFacet :
idx : int -> PolymeshFacet
Parameters
- idx Int32
-
A zero-based index of the facet
Return Value
PolymeshFacet
An instance of PolymeshFacet that represents
one facet defined by 3 vertices of the polymesh.
ExceptionsException | Condition |
---|
ArgumentException |
The given value is not a valid index of a facet of the polymesh.
A valid value is not negative and is smaller than the number of facets in the polymesh.
|
See Also