RebarSpliceUtilsCanRebarBeSpliced(Rebar, RebarSpliceOptions, Line, XYZ) Method |
Verifies if the rebar can be spliced with the provided line.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RebarSpliceError CanRebarBeSpliced(
Rebar rebar,
RebarSpliceOptions spliceOptions,
Line line,
XYZ linePlaneNormal
)
Public Shared Function CanRebarBeSpliced (
rebar As Rebar,
spliceOptions As RebarSpliceOptions,
line As Line,
linePlaneNormal As XYZ
) As RebarSpliceError
public:
static RebarSpliceError CanRebarBeSpliced(
Rebar^ rebar,
RebarSpliceOptions^ spliceOptions,
Line^ line,
XYZ^ linePlaneNormal
)
static member CanRebarBeSpliced :
rebar : Rebar *
spliceOptions : RebarSpliceOptions *
line : Line *
linePlaneNormal : XYZ -> RebarSpliceError
Parameters
- rebar Rebar
-
The rebar to be spliced.
- spliceOptions RebarSpliceOptions
-
The RebarSpliceOptions.
- line Line
-
The line to splice the rebar with.
- linePlaneNormal XYZ
-
The normal that determines the plane of the line.
Return Value
RebarSpliceError
Will return RebarSpliceError.Success if it's possible to splice with line or other enum value corresponding to the error that occurred.
Exceptions
Remarks If the provided linePlaneNormal is parallel with the bar plane normal the bounded line will be used to calculate the splice geometries where the bar will be split.
Otherwise, the line will be extended to exceed the bounding box of the bar.
See Also