CompoundStructureGetSimpleCompoundStructure Method |
Takes a horizontal slice through a sample wall to which this CompoundStructure is applied
and returns a simple compound structure which describes that slice, i.e. a series of
parallel layers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CompoundStructure GetSimpleCompoundStructure(
double wallHeight,
double distAboveBase
)
Public Function GetSimpleCompoundStructure (
wallHeight As Double,
distAboveBase As Double
) As CompoundStructure
public:
CompoundStructure^ GetSimpleCompoundStructure(
double wallHeight,
double distAboveBase
)
member GetSimpleCompoundStructure :
wallHeight : float *
distAboveBase : float -> CompoundStructure
Parameters
- wallHeight Double
-
The height of the wall.
- distAboveBase Double
-
The distance from the base of the wall at which to take the section.
If distAboveBase < 0, then internally distAboveBase = 0 is used.
If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.
Return Value
CompoundStructure
A simple CompoundStructure representing a series of parallel layers.
Remarks
See Also