FamilyManagerGetParameter Method

Obtains the family parameter with the given built-in parameter identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyParameter GetParameter(
	ForgeTypeId parameterTypeId
)

Parameters

parameterTypeId  ForgeTypeId
Identifier of the built-in parameter.

Return Value

FamilyParameter
Exceptions
ExceptionCondition
ArgumentException parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
ArgumentNullException A non-optional argument was NULL
Remarks
Returns if the parameter is not found.
See Also