ParameterUtilsGetBuiltInParameter Method |
Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static BuiltInParameter GetBuiltInParameter(
ForgeTypeId parameterTypeId
)
Public Shared Function GetBuiltInParameter (
parameterTypeId As ForgeTypeId
) As BuiltInParameter
public:
static BuiltInParameter GetBuiltInParameter(
ForgeTypeId^ parameterTypeId
)
static member GetBuiltInParameter :
parameterTypeId : ForgeTypeId -> BuiltInParameter
Parameters
- parameterTypeId ForgeTypeId
- The parameter identifier.
Return Value
BuiltInParameterThe BuiltInParameter value corresponding to the given parameter identifier.
ExceptionsException | Condition |
---|
ArgumentException |
parameterTypeId is not a built-in parameter identifier. See IsBuiltInParameter(ForgeTypeId) and GetParameterTypeId(BuiltInParameter).
|
ArgumentNullException |
A non-optional argument was NULL
|
See Also