RebarContainerItemSetHookTypeId Method |
Set the id of the RebarHookType to be applied to the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetHookTypeId(
int end,
ElementId hookTypeId
)
Public Sub SetHookTypeId (
end As Integer,
hookTypeId As ElementId
)
public:
void SetHookTypeId(
int end,
ElementId^ hookTypeId
)
member SetHookTypeId :
end : int *
hookTypeId : ElementId -> unit
Parameters
- end Int32
-
0 for the start hook, 1 for the end hook.
- hookTypeId ElementId
-
The id of a RebarHookType element, or invalidElementId if
the rebar should have no hook at the specified end.
Exceptions
See Also