RevitLinkTypeGetTopLevelLink(Document, ExternalResourceReference) Method |
Returns the ElementId of the (top-level) linked model with the given
ExternalResourceReference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetTopLevelLink(
Document document,
ExternalResourceReference reference
)
Public Shared Function GetTopLevelLink (
document As Document,
reference As ExternalResourceReference
) As ElementId
public:
static ElementId^ GetTopLevelLink(
Document^ document,
ExternalResourceReference^ reference
)
static member GetTopLevelLink :
document : Document *
reference : ExternalResourceReference -> ElementId
Parameters
- document Document
-
The document to look for the linked model in.
- reference ExternalResourceReference
-
An ExternalResourceReference indicating which linked model to return.
Return Value
ElementId
The id of the link with the given ExternalResourceReference,
or InvalidElementId if
there is no top-level link at that location.
Exceptions
RemarksThis function will not return nested links.
Revit will not check the version when checking for
resource equality.
See Also