ScheduleDefinitionAddEmbeddedSchedule Method |
Adds an embedded ScheduleDefinition.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddEmbeddedSchedule(
ElementId categoryId
)
Public Sub AddEmbeddedSchedule (
categoryId As ElementId
)
public:
void AddEmbeddedSchedule(
ElementId^ categoryId
)
member AddEmbeddedSchedule :
categoryId : ElementId -> unit
Parameters
- categoryId ElementId
-
The category ID of elements to display in the embedded schedule.
ExceptionsException | Condition |
---|
ArgumentException |
categoryId is not the ID of a category that can be used for an embedded
ScheduleDefinition in this ScheduleDefinition.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This ScheduleDefinition is not a kind of schedule that supports adding an embedded
ScheduleDefinition.
-or-
This ScheduleDefinition already has an embedded ScheduleDefinition.
|
See Also