ExporterIFCUtilsGetRelativeLocalPlacementOffsetTransform Method |
Obtains the relative transform between two IfcLocalPlacement handles.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Transform GetRelativeLocalPlacementOffsetTransform(
IFCAnyHandle originalPlacement,
IFCAnyHandle relativePlacement
)
Public Shared Function GetRelativeLocalPlacementOffsetTransform (
originalPlacement As IFCAnyHandle,
relativePlacement As IFCAnyHandle
) As Transform
public:
static Transform^ GetRelativeLocalPlacementOffsetTransform(
IFCAnyHandle^ originalPlacement,
IFCAnyHandle^ relativePlacement
)
static member GetRelativeLocalPlacementOffsetTransform :
originalPlacement : IFCAnyHandle *
relativePlacement : IFCAnyHandle -> Transform
Parameters
- originalPlacement IFCAnyHandle
-
The original placement from which the result transforms coordinates and directions.
- relativePlacement IFCAnyHandle
-
The relative placement to which the result transforms coordinates and directions.
Return Value
Transform
The transform from the original placement to the new placement.
Exceptions
See Also