CompoundStructureGetDeckProfileId Method |
Retrieves the profile loop used for the specified structural deck.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetDeckProfileId(
int layerIdx
)
Public Function GetDeckProfileId (
layerIdx As Integer
) As ElementId
public:
ElementId^ GetDeckProfileId(
int layerIdx
)
member GetDeckProfileId :
layerIdx : int -> ElementId
Parameters
- layerIdx Int32
-
Index of a layer in the CompoundStructure.
Return Value
ElementId
The element id of a FamilySymbol which contains a profile loop used by a structural deck associated to the specified layer,
or invalidElementId if isStructuralDeck(layerIdx) is false.
Exceptions
See Also