LinearArrayGetOriginalMemberIds Method

Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public override ICollection<ElementId> GetOriginalMemberIds()

Return Value

ICollectionElementId
The original member ids of the Array
Remarks
In the family environment, arrays with count 0 use the original elements as a placeholder item for the first array item. The ids of the original elements from which the array was created are returned even for arrays of count 0.
See Also