StructuralConnectionTypeSetFamilySymbolId Method |
FamilySymbol of the annotation to use for this connection type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFamilySymbolId(
ElementId familySymbolId
)
Public Sub SetFamilySymbolId (
familySymbolId As ElementId
)
public:
void SetFamilySymbolId(
ElementId^ familySymbolId
)
member SetFamilySymbolId :
familySymbolId : ElementId -> unit
Parameters
- familySymbolId ElementId
-
ExceptionsException | Condition |
---|
ArgumentException |
Thrown when familySymbolId is the id of some element that is not a
FamilySymbol, is not of the category "Connection
Symbols" (OST_StructConnectionSymbols), or has its "Apply
To" parameter not equal to this type's applyTo property.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The FamilySymbol must be of category "Connection Symbols"
(OST_StructConnectionSymbols) and have its "Apply
To" parameter set to match the applyTo property.
See Also