AnalyticalElementIsValidAnalyzeAs Method

Checks whether the value set for Analyze As is valid for an Analytical Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidAnalyzeAs(
	AnalyzeAs analyzeAs
)

Parameters

analyzeAs  AnalyzeAs
The value set to be verified.

Return Value

Boolean
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also