AnalyzeAs Enumeration

Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum AnalyzeAs
Members
Member nameValueDescription
Hanger0 A hanging Element.
Gravity1 Interpreted as Gravity (support going down).
Lateral2 Interpreted as Lateral (support going across).
SlabOneWay3 Floor interpreted as Slab One-Way.
Mat4 Floor interpreted as Mat Foundation, or general foundation.
SlabOnGrade5 Floor interpreted as Slab on a Grade.
NotForAnalysis7 Element is not for Analysis.
NotApplicable8 Analyze As is not applicable.
SlabTwoWay9 Floor interpreted as Slab Two-Way.
GravityLateral10 Wall interpreted as Gravity and Lateral
See Also