MechanicalSystemCreate(Document, ElementId, String) Method |
Creates a new instance of a mechanical system and adds it to the document.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MechanicalSystem Create(
Document ADocument,
ElementId typeId,
string name
)
Public Shared Function Create (
ADocument As Document,
typeId As ElementId,
name As String
) As MechanicalSystem
public:
static MechanicalSystem^ Create(
Document^ ADocument,
ElementId^ typeId,
String^ name
)
static member Create :
ADocument : Document *
typeId : ElementId *
name : string -> MechanicalSystem
Parameters
- ADocument Document
-
The document where the element will be created and added.
- typeId ElementId
-
The identifier of this mechanical system element's type.
- name String
-
The name of the mechanical system to be created.
Return Value
MechanicalSystem
The newly created mechanical system element.
Exceptions
See Also