RebarSpliceUtilsGetSpliceGeometries Method |
Computes a list of RebarSpliceGeometry which respects the rules. This list can be used to splice the Rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RebarSpliceByRulesResult GetSpliceGeometries(
Document document,
ElementId rebarIdToSplit,
RebarSpliceOptions spliceOptions,
RebarSpliceRules spliceRules
)
Public Shared Function GetSpliceGeometries (
document As Document,
rebarIdToSplit As ElementId,
spliceOptions As RebarSpliceOptions,
spliceRules As RebarSpliceRules
) As RebarSpliceByRulesResult
public:
static RebarSpliceByRulesResult^ GetSpliceGeometries(
Document^ document,
ElementId^ rebarIdToSplit,
RebarSpliceOptions^ spliceOptions,
RebarSpliceRules^ spliceRules
)
static member GetSpliceGeometries :
document : Document *
rebarIdToSplit : ElementId *
spliceOptions : RebarSpliceOptions *
spliceRules : RebarSpliceRules -> RebarSpliceByRulesResult
Parameters
- document Document
-
The document
- rebarIdToSplit ElementId
-
Rebar id to split.
- spliceOptions RebarSpliceOptions
-
The rebar splice options.
- spliceRules RebarSpliceRules
-
The splice rules.
Return Value
RebarSpliceByRulesResult
Returns the result of the operation. If the operation was successful the RebarSpliceByRulesResult.Error member will have "RebarSpliceByRulesError.Success" value.
Exceptions
See Also