MultistoryStairsCreate Method

Creates a multistory stairs from an existing component-based stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MultistoryStairs Create(
	Stairs stairs
)

Parameters

stairs  Stairs
A component-based stairs.

Return Value

MultistoryStairs
The newly created element. Use [M:Autodesk.Revit.DB.Architecture.MultistoryStairs.ConnectLevels(System.Collections.Generic.ISet`1{Autodesk.Revit.DB.ElementId})] to extend this to multiple stories and generate stairs groups for each level height.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also