IExternalDBApplication Interface |
An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IExternalDBApplication
Public Interface IExternalDBApplication
public interface class IExternalDBApplication
type IExternalDBApplication = interface end
The IExternalDBApplication type exposes the following members.
Methods | Name | Description |
---|
 | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down. |
 | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts. |
Top
RemarksDB-level applications are permitted to add DB-level events and updaters to the session.
They cannot create or modify UI.
See Also