IExternalDBApplicationOnStartup Method

Implement this method to execute some tasks when Autodesk Revit starts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
ExternalDBApplicationResult OnStartup(
	ControlledApplication application
)

Parameters

application  ControlledApplication
Handle to the Revit Application object.

Return Value

ExternalDBApplicationResult
Indicates if the external db application completes its work successfully.
Remarks
Typically, event handlers and updaters are registered in this method.
See Also