RebarHandlePositionDataGetBarGeometry Method |
Returns the geometry for a bar at the specified index currently in the Rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Curve> GetBarGeometry(
int barIndex
)
Public Function GetBarGeometry (
barIndex As Integer
) As IList(Of Curve)
public:
IList<Curve^>^ GetBarGeometry(
int barIndex
)
member GetBarGeometry :
barIndex : int -> IList<Curve>
Parameters
- barIndex Int32
-
The index of the bar. Should be a number between 0 and GetNumberOfBars() - 1.
Return Value
IListCurve
Returns an array of curves that defines the bar at the specified index.
Exceptions
See Also