NumberingSchemaNumberingParameterId Property |
Id of the parameter that stores values of the numbers on enumerated elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId NumberingParameterId { get; }
Public ReadOnly Property NumberingParameterId As ElementId
Get
public:
property ElementId^ NumberingParameterId {
ElementId^ get ();
}
member NumberingParameterId : ElementId with get
Property Value
ElementId
RemarksValues of numbers can be obtained by querying this parameter for the respective numbered element.
The value is read-only and thus cannot be set; it is always computed based on the order of created
elements and the matching policy within each numbering sequence.
Note: Although the parameter cannot be changed directly, it can be modified indirectly
(with restrictions) using the ChangeNumber(String, Int32, Int32) method.
See Also