PolymeshTopologyNumberOfNormals Property |
The number of normals associated with the polymesh
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int NumberOfNormals { get; }
Public ReadOnly Property NumberOfNormals As Integer
Get
public:
property int NumberOfNormals {
int get ();
}
member NumberOfNormals : int with get
Property Value
Int32
Remarks
The number is always equal either to '1', or the number of facets,
or the number of points. The DistributionOfNormals property indicates
how normals are distributed along the polymesh. If there is only one normal available,
it applies to the entire mesh. Curved surfaces have normal vectors associated
with either every facet or every point/vertex of the tessellated polymesh.
See Also