ParameterFilterElementAllRuleParametersApplicable(Document, ICollectionElementId, ElementFilter) Method |
Checks that the parameters of the given ElementFilter (representing a combination of rules)
are valid for the given set of categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool AllRuleParametersApplicable(
Document aDocument,
ICollection<ElementId> categories,
ElementFilter elementFilter
)
Public Shared Function AllRuleParametersApplicable (
aDocument As Document,
categories As ICollection(Of ElementId),
elementFilter As ElementFilter
) As Boolean
public:
static bool AllRuleParametersApplicable(
Document^ aDocument,
ICollection<ElementId^>^ categories,
ElementFilter^ elementFilter
)
static member AllRuleParametersApplicable :
aDocument : Document *
categories : ICollection<ElementId> *
elementFilter : ElementFilter -> bool
Parameters
- aDocument Document
-
The document containing the filter, categories, and parameters involved in this validation.
- categories ICollectionElementId
-
The set of categories against which to check the rule parameters.
- elementFilter ElementFilter
-
The ElementFilter representing the combination of rules to check.
Return Value
Boolean
True if all the parameters of the given rules are valid for this filter, otherwise false.
Exceptions
See Also