ColumnAttachmentIsValidTarget(FamilyInstance, Element) Method |
Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidTarget(
FamilyInstance column,
Element target
)
Public Shared Function IsValidTarget (
column As FamilyInstance,
target As Element
) As Boolean
public:
static bool IsValidTarget(
FamilyInstance^ column,
Element^ target
)
static member IsValidTarget :
column : FamilyInstance *
target : Element -> bool
Parameters
- column FamilyInstance
-
The column to attach. If the target is a beam or brace, the column
will be checked to see if it is slanted. Otherwise, this argument
is not used and may be omitted.
- target Element
-
A proposed target element for a column attachment.
Return Value
Boolean
Exceptions
Remarks
Valid targets are roofs, floors, and ceilings. Beams and braces
are also valid targets, except for slanted columns.
See Also