IdlingEventArgs Class

The event arguments used by the Idling event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.UI.EventsIdlingEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IdlingEventArgs : RevitAPIPreEventArgs

The IdlingEventArgs type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodSetRaiseWithoutDelay Sets the next invocation of the idling event to be called promptly, rather than relying on the default recurrence of idling from the Revit application. For more details see the remarks describing the Idling event.
Top
See Also